Problem with plotting SP Google map

Sep 27, 2011 at 4:29 PM
Edited Sep 27, 2011 at 4:30 PM

Dear Axel,

I have tried your solution and it seems to work great, extremely useful for us. However, once markers have been plotted on a map they stay at those exact locations although I have changed the latitudes and longitudes of the items in the list. I wonder what I may be doing wrong, there seem to be some memory variables that are not updated.

Many thanks for this work and kind regards, 

Ad

Coordinator
Sep 27, 2011 at 6:30 PM

Hi Ad,

I have tested the behaviour but could not reproduce the explained behaviour. Please provide some further details so that I could reproduce the behaviour.

Without the chance to reproduce the behaviour I have to guess the possible cause by asking some questions:

  • Do you use proxy-server within your network?
  • Do you use caching-settings in your browser?
  • Do you use caching-settings in your SharePoint-Server?
  • Do you use a supported Browser (have a look at the documentation)?
  • Do you use publishing-algorithm (e.g. content-approval) within your SharePoint-list? 
  • Did you test the behaviour for a very simple list (e.g. standard contact-list + coordinate-columns)?

Many regards,

Axel

Sep 27, 2011 at 7:35 PM

Many thanks Alex,

I actually do not know much of how the server operates. There may be some caching, but with other data in Sharepoint I do not see this problem happening. We use MS explorer as browser. The list I am using is indeed simple, I am just testing at this stage.

It seems though that if I replace a list item instead of editing the column field containing the coordinates, I do not have any problem. It therefore is not a major issue, we should simply enter the coordinates correctly and not change later.

By the way, would it be possible to replace the marker by an icon image depending on the content of a choice-column, e.g. a waterpump image for a location where pumps are out of order or a tent image for a location where refugees are in temporary camps?

Many thanks,

Ad

Van: aschneider [email removed]
Verzonden: dinsdag 27 september 2011 20:31
Aan: Beljaars, Ad
Onderwerp: Re: Problem with plotting SP Google map [SPGoogleMapsWPForSPL:274005]

From: aschneider

Hi Ad,

I have tested the behaviour but could not reproduce the explained behaviour. Please provide some further details so that I could reproduce the behaviour.

Without the chance to reproduce the behaviour I have to guess the possible cause by asking some questions:

  • Do you use proxy-server within your network?
  • Do you use caching-settings in your browser?
  • Do you use caching-settings in your SharePoint-Server?
  • Do you use a supported Browser (have a look at the documentation)?
  • Do you use publishing-algorithm (e.g. content-approval) within your SharePoint-list?
  • Did you test the behaviour for a very simple list (e.g. standard contact-list + coordinate-columns)?

Many regards,

Axel



Dit bericht is uitsluitend bestemd voor de geadresseerde.
Het bericht kan vertrouwelijke informatie bevatten.
Als u dit bericht per abuis hebt ontvangen, wordt u verzocht het te vernietigen en de afzender te informeren.
Het Nederlandse Rode Kruis is niet aansprakelijk voor onjuiste en onvolledige overbrenging van de inhoud van een verzonden e-mail bericht, of een te late ontvangst daarvan.

This message is intended exclusively for the addressee.
It may contain information that is confidential.
If you are not the intended recipient please notify the sender immediately and destroy this message.
The Netherlands Red Cross is neither liable for the proper and complete transmission of the information contained in this communication nor for any delay in its receipt.
May 1, 2012 at 1:53 PM

I've encountered this problem as well. It is due to caching in Internet Explorer. Updating is working correctly with Firefox, Opera and Chrome.

In my case the caching issue is due to a faulty domain policy. Non-MicroSoft browsers ignore this policy. But users of Internet Explorer can not avoid this policy.

Coordinator
Oct 23, 2012 at 6:43 PM

Hi MarkScholtens! Did you remember the name of the domain-policy you noticed in your last comment? It would be interesting to avoid similar problems in the future.